
SuperBladePro
Flaming Pear Software

What it does

SuperBladePro gives graphics a 3-D look by creating beveled edges and surface 
textures. The effects can be subtle or stark, raised or sunken. You can do  
bevels, textures, and mirror-like reflections. There are controls for lighting, 
gloss, iridescence, tarnish, glassiness, and more — it’s a timesaving way to make 
touchable-looking text, buttons, and special effects.
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How to install

Illustrated installation instructions are online at www.flamingpear.com/faq.html .

To use this software, you need a paint program which accepts standard 
Photoshop 3.02 plugins.

Just put the plug-in filter into the folder where your paint program expects to 
find it. If you have Photoshop, the folder is Photoshop:Plugins:Filters or 
Photoshop:Plug-ins. You must restart Photoshop before it will notice the new 
plug-in. It will appear in the menus as Filters->Flaming Pear->SuperBladePro.

Most other paint programs follow a similar scheme.

If you have Paint Shop Pro: you have to create a new folder, put the plug-in filter 
into it, and then tell PSP to look there.

PSP 7:

Choose the menu File-> Preferences-> File Locations... and choose the Plug-in 
Filters tab. Use one of the “Browse” buttons to choose the folder that contains 
the plug-in.

The plug-in is now installed. To use it, open any image and select an area. From 
the menus, choose Effects->Plug-in Filters->Flaming Pear->SuperBladePro.

PSP 8, 9, X, and later:

Choose the menu File-> Preferences-> File Locations... In the dialog box that 
appears, choose Plug-ins from the list. Click “Add.” If you are using PSP 8 or 9, 
click “Browse”. Now choose the folder that contains the plug-in.

The plug-in is now installed. To use it, open any image and select an area. From 
the menus, choose Effects->Plugins->Flaming Pear->SuperBladePro.
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Quick start

When you invoke SuperBladePro, a dialog box will appear.
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In your paint program, select a shape with the lasso 
tool, then start SuperBladePro.

Click the dice button a few times until you see 
something you like.

Click OK. The progress bar will appear, and then 
your selection will have a new 3-D look.

If you want to exert fine control over the result, it helps to learn the controls 
which govern shape, lighting, and appearance. 

Shape

Bring the filter back and take a look at the controls. On left are a popup menu 
and several sliders.

Shape sets the shape of the bevel. Choose from 
straight, curved, up-and-down, and doubled forms. 
The last shape is a Gaussian bevel which produces a 
very smooth result at the expense of some detail.

Radius The width, in pixels, of the beveled edge.

Height Larger values here make the bevel steeper. 
Positive values make the selection rise out of its 
background, and negative values make it sink in.

Smoothness Larger values reduce the rippled 
appearance of the bevel.

Texture specifies the strength of the texturing. Positive 
values make the texture rise out of the bevel, negative 
ones make it sink in.

Embossing make the brightness of the underlying image influence the shape.

4

bevel shapes

dice



Light

Light angle controls are the two grey spheres. To 
change the placement of a light, drag the small blue 
dot to a new position. Best results come from placing 
the light somewhere in the upper half of the ball.

Spotlight sliders next to the light angle controls can 
produce uniform illumination or a spotlight effect.

Color buttons are for changing the lights’ colors. To 
turn a light completely off, set its color to black.

Gloss

Gloss controls shininess. Zero gives a chalky 
appearance. Higher numbers are glossier.

Glare controls the size of the glossy highlight.

Reflection controls how much the selection reflects the 
Environment graphic. If you don’t want any reflection at 
all, use zero.
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Glassiness gives the selection a glassy appearance. 
The color of the original image becomes the color of 
the glass.

Caustic controls the brightness of the caustic highlight 
that appears opposite the light source. In only works 
when glassiness is turned on.  The checkbox just to the 
right of the slider lets you choose prismatic or white 
caustics.

Iridescence controls the strength of iridescent 
coloration.

Iri colors controls the choice of iridescent colors.

Together, Caustic and Iridescence reproduce the effect 
that gives soap bubbles their rainbow colors.

Textures and reflections

Texture popup menu chooses a texture. The first item 
is ‘no texture’; the next eleven items are built-in 
textures; and the last item is the custom texture.

You can use any greyscale PICT file (on Macintosh) or 
BMP file (on Windows) as a custom texture. To do this, 
select the custom texture item from the popup menu, 
and use the file browser to choose a picture from disk.

The texture graphic is just below. Clicking on it is 
another way you can load a new texture file. You can 
reposition the texture by dragging it with the mouse.

Texture files are “height fields” and describe the shape 
of a surface. Black is low, white is high, grey is in 
between. SuperBladePro comes with several texture files 
in its ‘environments and textures ‘ folder, and you can 
make your own. They can be as large as 256 by 256 
pixels. Larger ones will be squeezed to fit. The right 
edge should wrap seamlessly around to the left, and 
the top to the bottom.
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The texture zoom slider is right below the texture graphic. It can scale the 
texture up or down by a factor of 16.

Next is the environment graphic: When Reflection is 
on, Blade will produce mirror-like reflections of the 
environment graphic. Just click on the graphic and you 
can load any PICT file (on Macintosh) or BMP file (on 
Windows) as an environment. You can find several 
samples in the ‘environments and textures’ folder that 
came with SuperBladePro.

If you don’t want reflections, set the reflection slider to 
zero.

Some of the example environments, like ‘gold’, appear 
to contain their own light source coming from the top 
left. If that conflicts with your design plan, you can spin the environment with 
the environment spinner button, so that it better matches the rest of the 
lighting. This button is the one with the little curly arrow on it.

 


Rain

SuperBladePro can simulate water stains. This uses four sliders:

Rain is the amount of water falling from the top of the 
selection.

Evaporation sets the rate at which water evaporates. If 
evaporation is greater than rain, water stains may only 
appear near wrinkles in the surface.
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Diffusion controls the horizontal spread of the water

Wander makes water wander over flat areas instead of 
falling straight down.

There are two rain color buttons. As rain becomes 
heavier, the color changes from the first color to the 
second.

A wet/dry checkbox controls whether the rain acts like 
opaque paint or transparent dye.
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Weathering

Dust makes dull powder appear on upward-facing 
surfaces.

Grit puts high-frequency noise in the texture.

Tarnish puts dull, matte color in the concave parts of 
the surface. The color button just to the right of the 
slider lets you change the tarnish color.

Abrasion is like Tarnish, but puts dirt on convex areas.

Moss puts moss on upward-facing surfaces.

Moss has two color buttons: one for the moss itself, 
one for the underlying soil.

Leakiness makes the moss leak water, and makes the 
blotches soak in the resulting stains.

Blotches grows lichen-like blobs. Blotches have color, 
scale, and coverage controls.

Blotch Size makes the blotches bigger or smaller.

The random seed nearby changes the detail of the 
blotches. You can click it repeatedly until you see the 
effect you like.
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Other controls

Dice: The dice choose a random effect. Click as much as you 
want to see different effects.

Reset: Gives you the “factory settings,” a plain bevel.

Glue mode popup: menu Lets you combine the result with 
the underlying image in various ways. Modes other than 
“normal” produce special effects. The next-glue button 
advances to the next glue mode.

Send to photo manager: Sends the result to iPhoto (on 
Macintosh).

Export to PSD: Renders the result to a a .psd image file.

Plus, % and minus buttons: If the selected image area is 
bigger than the preview, these buttons let you zoom in and 
out. Drag the preview to move it.

Make Gallery: Does three things:

—If you have a folder full of presets from original BladePro, 
you can automatically turn them into SuperBladePro presets 
containing previews.

—You can make a web page showing all your texture and environment images.

—You can make a web page that displays all the presets’ previews, and lists 
which environment and texture files they use.

10

dice

reset

next glue

send to photo manager

export to PSD

minus, %, plus

make gallery



Load preset: SuperBladePro comes with some presets, 
which are files containing settings. To load one, click 
this button and browse for a preset file.

The presets expect their texture and environment files 
to be in the ‘environments and textures’ folder. If 
presets fail to load properly, SuperBladePro will ask you 
where that folder is. The Installation section of this 
guide explains in more detail.

Save preset: When you make an effect you like, click 
this button to save the settings in a file. 

Undo: backs up one step.

Info: Briefly explains the controls.

Three more buttons:

OK:  Applies the effect to your image.

Cancel:  Dismisses the plug-in, and leaves the image 
unchanged.

Register: Allows you to type in a registration code and 
remove the time limit from the demo. 
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Memory dots

Although you can save your settings permanently to 
files, you can also stash settings in memory dots.

Click an empty dot to stash the current settings in it.

Click a full dot to retrieve its settings.

Hover the mouse over a dot to see what it contains.

Option-click to erase a dot on Macintosh.

Right-click to erase a dot on Windows.

If a dot is orange, LunarCell’s currently using that dot’s 
settings.

Dots remember their contents until you erase them. If 
you’d rather make a temporary dot that forgets when 
you exit LunarCell, control-click it. Temporary dots are 
square.

When you start LunarCell, it puts the starting settings 
in a temporary dot. That way it’s easy to start over 
without exiting the plug-in.

On Mac, you can drag-and-drop settings files from the 
central memory well.

You can build a web page showing how the current 
image would look with every memdot setting. Just 
option-click (Mac) or right-click (Windows) on the big 
memdot image.
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Five effects you can try

More presets and tutorials appear here and here.

A ruby

Make a selection with some straight sides and fill it 
with ruby-red. Bring up SuperBladePro and decide how 
you want your ruby to look.

Adjust the Shape and Radius and Height to produce a shape with some internal 
edges in it.

Rubies are glassy, so set Glassiness to about 90. You want it to appear sparkly 
and reflective, so set Gloss to about 50, Glare to 50, Reflection to 75. Choose an 
environment with flattering colors in it: ‘Rum’ is nice.

To increase sparkle further, turn Caustic up to 60 to produce a highlight away 
from the light. Even better, use both light sources: move the second one to 
about the 2 o’clock position, and set its color to creamy yellow.

Introduce more variety of color by turning Iridescence to about 15 and putting 
the Iri Colors slider somewhere in a pink-and-yellow region.

Subtle texture will make your ruby look best. Click the texture graphic and load 
the texture file called ‘ripples2’. Set the Texture slider to something between 10 
and 30, and experiment with the Texture Zoom until you like the result.

Click OK. There’s your ruby. 

Tarnished metal

Select a region of your image, and call up 
SuperBladePro.

Load the preset called ‘old copper’. The important 
elements here are 100% reflection of a coppery 
environment, a wavy texture, some pale green tarnish like corroded copper, and 
a light source at the upper left, which matches the light in the environment map.
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If the real light and the light in the environment don’t match, the tarnish will 
look wrong. If you want, try moving the light source and spinning the 
environment to see how they need to be in sync.

The tarnish collects in the concave parts of the surface, so it will react to the 
scale and height of the texture, as well as the crevices in some of the bevel 
shapes. Try changing those settings and the tarnish amount and color to see 
how they interact.

Try some other combinations: the environment ‘city’ with black tarnish looks like 
dirty silver. The ‘dull steel’ environment with brick-red tarnish looks like rust; 
strange tarnish colors like magenta give a surreal effect.

Good textures to use with tarnish are ‘scales’, ‘pits’, ‘crackle’, and ‘dimples’. And 
try the preset called ‘my tailpipe’ to see a oxidized metal effect that uses tarnish 
and iridescence together. 

A web button

Suppose you want to make a web button that has the word 
“Go” on it.

In your paint program, paint an area in some pale color. With your text tool, 
make the word “Go” in green.

Using your favorite selection tool, with antialiasing turned on, select a a button-
shaped area around the word.

Bring up SuperBladePro. Click the Load button (it looks like a CD with a blue 
triangle pointing from it) . Navigate to your ‘environments and textures’ folder 
and open the preset called ‘button, basic’.

After the preset loads, the preview should show your button with a basic bevel 
effect.

Play with the controls. The Radius control changes the width of the bevel. The 
Shape, Height, and Texture controls, in particular, let you make the most useful 
changes.

Click OK. There’s your button.

For a more sophisticated effect, make a button as above but without the word 
“Go”. Instead, make a blank button. Then, in a new layer, make a selection in the 
shape of the word “Go” and use SuperBladePro to make the word look like gold; 
use the preset called called ‘gold, basic’. Last, settle the word “Go” on the button 
by giving it a drop shadow.
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Iridescent surfaces

Select a part of your image, and call up SuperBladePro, and 
load the preset called ‘ski goggles 1’.

The selection reflects a nearly colorless environment, but the 
iridescence adds plenty of color to the result. The Iridescence 
slider controls the strength of the added color, and the Iri Colors slider decides 
the range of possible hues.

The final outcome of colors will react to the shape of the bevel and the strength 
of the texture, so try changing those settings to get a feel for how the colors 
change. The more strongly sloped the surface gets, the wider variety of colors it 
will have.

The Iri Colors slider produces assorted effects. At zero, iridescence disappears. 
At very small values, about 7, surfaces become dull brown, like slightly oxidized 
metal. At 12, you have an anti-reflective coating. Soap bubbles are about 25, and 
higher values give the hues you see in ski goggles and sunglasses.

Adding a very small amount of iridescence can create attractive variation in hue 
in any effect. Check out the preset ‘my tailpipe’ and change its iridescence 
settings to see what’s possible. 

A glassy logo

Use your text tool to write a word in 50% gray, using 
a large, husky font - say, Gill Sans Bold at 100 pt.

Make sure the text is selected, and call up 
SuperBladePro. Load the ‘rainbow glass’ preset. The word should now appear as 
glass with a bright rainbow caustic.

Play with the controls. Try a white caustic, or a different environment, or a 
different degree of glassiness or reflectivity.

Click OK if you like the effect.

If you want to experiment with colored glass, cancel out of the filter, and use 
your paint tools to paint each letter a different color. Moderately saturated tones 
at about half of full brightness work best. Then go back into the filter and see 
how the colored glass looks.
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Hints

Selections with an antialiased edge will yield vastly better results than ones with 
hard edges. Most paint programs can create an antialiased edge for text-shaped 
and freehand selections.

The environment and texture graphics can be any PICT (on Macintosh) or BMP 
(on Windows), and you can use your paint software to make your own. Included 
with SuperBladePro are...

Environments

2am

bronze sunset

cheap gold

city

copper

Curacao

driftwood

dull steel

glitter

gold

hillside

island

la-la land

puffy

red copper

road

rum

sea & sky

tinsel

watery
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white chrome

winter

big city

canal

chinarock

cove

empire

greenstairs

lumphini

samui

victoria sky

zwolle

Textures

burrs

cow

crackle

crumples

dendrites

dimples

fibrous

grass

lumps

pits

plaster

ringlets

ripples2

ruffles
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scales

silk

tumor

turbulence

You can use the preset management feature to keep track of your environments 
and textures.

Free SuperBladePro tutorials and extra textures are available at http://
www.flamingpear.com/download.html .

If you want to make your own metal environments, it aids realism to make the 
bright parts slightly bluer and the dark parts slightly redder than your base hue.

If you want to produce a scene with shiny objects in front of some backdrop, you 
can use a small (64x64 pixels or so) version of the backdrop as your 
environment map. This way the shiny objects will match their background. 
There’s an example of this online.

Constructing a 3-D shape from a selection’s edge results in a slightly ripply 
surface, so reflections tend to have fine striations in them. For that reason, the 
best results come from environments with contrasty ramps of color and a bare 
minimum of detail. Take a look at the included samples to get an idea.

You can use bevels with a small radius and negative height to create a chiseled 
edge.

SuperBladePro can be used purely as a texture generator; just set Bevel Height to 
zero, and reduce Radius to the minimum. Try this using the texture ‘dimples’ 
and some tarnish.

You can make your own textures: dark areas are low, bright areas are high. Try 
this recipe:

Find an interesting piece of a some image.

Use the cloning brush to make a roughly square, roughly homogenous 
chunk

Gaussian Blur by about 0.5 pixels

Adjust->Auto Levels

Use the highpass filter on it, radius 4 to 8 pixels

Adjust->Auto Levels again
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Wrap the edges of the selection to make a seamless tile.

Try inverting the grey values of the whole image. If the picture becomes 
generally darker, then use the inverted picture. That way, positive settings of the 
texture slider will produce bumps, and negative settings pits.

Version History

Version 1.8

64-bit version for Windows.

Version 1.7

Adds convenience features to the interface. The Mac version is resizable.

Version 1.5.2

Fixes a Macintosh problem where the plug-in could have bad settings or crash 
when installed on a machine for the first time.

Version 1.5

Universal Binary for Macintosh. Fixes a Windows problem where the plug-in 
wouldn’t remember its registration when it was installed in one user account but 
activated in another.

Version 1.45

Fixes the result when used in a 16-bit layer.

Version 1.42

Faster. Does not forget settings when used with Paint Shop Pro 9.
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Version 1.4

Works with 16-bit-per-component color.

Version 1.3a

Fixes incorrect results with floating selections in PSP8.

Version 1.3

Adds dozens of new glue modes.

Version 1.2

Recordable as a Photoshop action.

Version 1.1

Adds the preset-management feature. Changes the behavior of zoomed-out 
selections in PSP8 again.

Version 1.09a

Makes the big previews work more reliably. Fixes the numeric display of the 
texture-zoom slider in the Mac OS X version.

Version 1.09

Adds bigger previews in the preset browser. Adds a button for automatically 
updating a whole folder of presets.

Version 1.08

Fixes the appearance of zoomed-out views in Paint Shop Pro 8 .

Version 1.07

Fixes the appearance of text in the interface when running under Mac OS X 
10.2.3 .
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Version 1.06

Fixes a bug in the both the Windows and Macintosh versions where loading 
presets would sometimes cause spurious error messages.

Version 1.04

Fixes yet a third bug in the Macintosh version where presets would sometimes 
not load their texture and environment files. This version is PowerPC only.

Version 1.02

Fixes another bug in the Macintosh version where presets would sometimes not 
load their texture and environment files.

Version 1.01

Fixes a bug in the Macintosh version where presets would sometimes not load 
their texture and environment files.

Version 1.0

The first public release. Novel features include water stains, blotches, abrasion, 
spotlighting, dust, grit, embossing, moss, and smooth Gaussian bevels. The 
Windows version will operate correctly even if Windows is installed on a drive 
other than C:.
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How to purchase

You can place an order online here. A secure server for transactions is available.

Questions

The software, documentation, and supporting materials are made by Flaming 
Pear Software. Answers to common technical questions appear on our support 
page, and free updates appear periodically on the download page.

Trouble with your order? Orders are handled by Kagi; please contact them at 
admin@kagi.com .

For bug reports and technical questions about the software, please write to 
support@flamingpear.com .

©2010 Flaming Pear Software
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